# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)"
test_str = (" <div class=\"mr-data-inputfield\">\n"
" @Html.LabelFor(m => m.Device.ShortDescription)\n"
" @Html.TextBoxFor(m => m.Device.ShortDescription, new { style = \"width: 400px;\" })\n"
" @Html.ValidationMessageFor(m => m.Device.ShortDescription)\n"
" </div>\n"
" <div class=\"mr-data-inputfield\">\n"
" @Html.LabelFor(m => m.Device.LongDescription)\n"
" @Html.TextAreaFor(m => m.Device.LongDescription)\n"
" @Html.ValidationMessageFor(m => m.Device.LongDescription)\n"
" </div>")
subst = "<div class=\"form-group\">\\n\\t\\2, new { @class = \"control-label\" })\\n\\t<div class=\"input-group\">\\n\\t\\t\\3, new { @class = \"form-control\" })\\n\\t\\t\\4\\n\\t</div>\\n</div>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.