package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s+(<.+>)\s+(@.+)\)\s+(@.+)\)\s+(@.+\))\s+(<.+>)`)
var str = ` <div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = "width: 400px;" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>`
var substitution = "<div class="form-group">\n\t\2, new { @class = "control-label" })\n\t<div class="input-group">\n\t\t\3, new { @class = "form-control" })\n\t\t\4\n\t</div>\n</div>\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}