const regex = new RegExp('\\s+(<.+>)\\s+(@.+)\\)\\s+(@.+)\\)\\s+(@.+\\))\\s+(<.+>)', 'gmi')
const str = ` <div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.ShortDescription)
@Html.TextBoxFor(m => m.Device.ShortDescription, new { style = "width: 400px;" })
@Html.ValidationMessageFor(m => m.Device.ShortDescription)
</div>
<div class="mr-data-inputfield">
@Html.LabelFor(m => m.Device.LongDescription)
@Html.TextAreaFor(m => m.Device.LongDescription)
@Html.ValidationMessageFor(m => m.Device.LongDescription)
</div>`;
const subst = `<div class="form-group">\n\t\2, new { @class = "control-label" })\n\t<div class="input-group">\n\t\t\3, new { @class = "form-control" })\n\t\t\4\n\t</div>\n</div>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);