using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(email|phone)\"":[^,]*,?";
string substitution = @"""$1"":""****""";
string input = @"""email"": abc@rrr.ttt,
""phone"":""1234545353""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}