const regex = new RegExp('\\"(email|phone)\\":[^,]*,?', 'gm')
const str = `"email": abc@rrr.ttt,
"phone":"1234545353"`;
const subst = `"$1":"****"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);