re = /\"(email|phone)\":[^,]*,?/m
str = '"email": abc@rrr.ttt,
"phone":"1234545353"'
subst = '"$1":"****"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result