$re = '/\"(email|phone)\":[^,]*,?/m';
$str = '"email": abc@rrr.ttt,
"phone":"1234545353"';
$subst = "\"$1\":\"****\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;