use strict;
my $str = '"email": abc@rrr.ttt,
"phone":"1234545353"';
my $regex = qr/\"(email|phone)\":[^,]*,?/mp;
my $subst = '"$1":"****"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";