# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)([^\w\s]+)/$2$1/gu;t' <<< "fine just working line English my Is?
does it hope I...
English in continued be to is this and..."