const regex = /(\w+)([^\w\s]+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)([^\\w\\s]+)', 'gu')
const str = `fine just working line English my Is?
does it hope I...
English in continued be to is this and...`;
const subst = `$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);