using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)([^\w\s]+)";
string substitution = @"$2$1";
string input = @"fine just working line English my Is?
does it hope I...
English in continued be to is this and...";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}