// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(\w+)([^\w\s]+)").unwrap();
let string = "fine just working line English my Is?
does it hope I...
English in continued be to is this and...";
let substitution = "$2$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}