re = /(\w+)([^\w\s]+)/
str = 'fine just working line English my Is?
does it hope I...
English in continued be to is this and...'
subst = '$2$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result