# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\\/board\\/(.*)t(\d+)\.html$/http:\/\/example.com\/forum\/$1$2 permanent;/;t' <<< "/board/here-is-the-title-t1234.html"