re = /^\/board\/(.*)t(\d+)\.html$/
str = '/board/here-is-the-title-t1234.html'
subst = 'http://example.com/forum/$1$2 permanent;'
result = str.sub(re, subst)
# Print the result of the substitution
puts result