use strict;
my $str = '/board/here-is-the-title-t1234.html';
my $regex = qr/^\/board\/(.*)t(\d+)\.html$/p;
my $subst = 'http://example.com/forum/$1$2 permanent;';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";