import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/board\\/(.*)t(\\d+)\\.html$";
final String string = "/board/here-is-the-title-t1234.html";
final String subst = "http://example.com/forum/$1$2 permanent;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}