using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/board\/(.*)t(\d+)\.html$";
string substitution = @"http://example.com/forum/$1$2 permanent;";
string input = @"/board/here-is-the-title-t1234.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}