// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\/board\/(.*)t(\d+)\.html$").unwrap();
let string = "/board/here-is-the-title-t1234.html";
let substitution = "http://example.com/forum/$1$2 permanent;";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}