#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\d*\.?\d*)[\.\d]*$"
Local $sString = "1.2" & @CRLF & _
"" & @CRLF & _
"30.5" & @CRLF & _
"13.54" & @CRLF & _
"25.65" & @CRLF & _
"1.3" & @CRLF & _
".3" & @CRLF & _
"4.5" & @CRLF & _
".2" & @CRLF & _
".3,.4,.5" & @CRLF & _
"12,13.37,.4,11" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"999,33" & @CRLF & _
"0.33.333" & @CRLF & _
"-0.01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")