// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d*\.?\d*)[\.\d]*$").unwrap();
let string = "1.2
30.5
13.54
25.65
1.3
.3
4.5
.2
.3,.4,.5
12,13.37,.4,11
1
2
3
999,33
0.33.333
-0.01";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}