package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d*\.?\d*)[\.\d]*$`)
var str = `1.2
30.5
13.54
25.65
1.3
.3
4.5
.2
.3,.4,.5
12,13.37,.4,11
1
2
3
999,33
0.33.333
-0.01`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}