import Foundation
let pattern = #"^(\d*\.?\d*)[\.\d]*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.2
30.5
13.54
25.65
1.3
.3
4.5
.2
.3,.4,.5
12,13.37,.4,11
1
2
3
999,33
0.33.333
-0.01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}