import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d*\\.?\\d*)[\\.\\d]*$";
final String string = "1.2\n\n"
+ "30.5\n"
+ "13.54\n"
+ "25.65\n"
+ "1.3\n"
+ ".3\n"
+ "4.5\n"
+ ".2\n"
+ ".3,.4,.5\n"
+ "12,13.37,.4,11\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "999,33\n"
+ "0.33.333\n"
+ "-0.01";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}