# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d*\.?\d*)[\.\d]*$"
test_str = ("1.2\n\n"
"30.5\n"
"13.54\n"
"25.65\n"
"1.3\n"
".3\n"
"4.5\n"
".2\n"
".3,.4,.5\n"
"12,13.37,.4,11\n"
"1\n"
"2\n"
"3\n"
"999,33\n"
"0.33.333\n"
"-0.01")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.