const regex = /^(\d*\.?\d*)[\.\d]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*\\.?\\d*)[\\.\\d]*$', '')
const str = `1.2
30.5
13.54
25.65
1.3
.3
4.5
.2
.3,.4,.5
12,13.37,.4,11
1
2
3
999,33
0.33.333
-0.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}