$re = '/^(\d*\.?\d*)[\.\d]*$/';
$str = '1.2
30.5
13.54
25.65
1.3
.3
4.5
.2
.3,.4,.5
12,13.37,.4,11
1
2
3
999,33
0.33.333
-0.01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);