# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<tr>)[\s\S]+?(?=<\\/tr>)/x/gm;t' <<< "<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>"