const regex = /(?<=<tr>)[\s\S]+?(?=<\/tr>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<tr>)[\\s\\S]+?(?=<\\\/tr>)', 'gm')
const str = `<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);