$re = '/(?<=<tr>)[\s\S]+?(?=<\/tr>)/m';
$str = '<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;