#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<tr>)[\s\S]+?(?=<\/tr>)"
Local $sString = "<div>simple div</div>" & @CRLF & _
"<tr><td>test</td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>" & @CRLF & _
"test" & @CRLF & _
"</td>" & @CRLF & _
"" & @CRLF & _
"</tr>"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)