re = /(?<=<tr>)[\s\S]+?(?=<\/tr>)/m
str = '<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result