using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<tr>)[\s\S]+?(?=<\/tr>)";
string substitution = @"x";
string input = @"<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}