import Foundation
let pattern = #"(?<=<tr>)[\s\S]+?(?=<\/tr>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)