use strict;
my $str = '<div>simple div</div>
<tr><td>test</td></tr>
<tr>
<td>
test
</td>
</tr>';
my $regex = qr/(?<=<tr>)[\s\S]+?(?=<\/tr>)/mp;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";