#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])"
Local $sString = "SMThingAnotherThingBIGCapitalLetters Test" & @CRLF & _
"" & @CRLF & _
"TTttTtest" & @CRLF & _
"" & @CRLF & _
"TTT "
Local $sSubst = "\1\2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)