const regex = /([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])', 'gm')
const str = `SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT `;
const subst = `\1\2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);