import Foundation
let pattern = #"([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)