$re = '/([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])/m';
$str = 'SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT ';
$subst = "\1\2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;