re = /([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])/m
str = 'SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT '
subst = '\\1\\2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result