use strict;
my $str = 'SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT ';
my $regex = qr/([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])/mp;
my $subst = '\\1\\2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";