import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])";
final String string = "SMThingAnotherThingBIGCapitalLetters Test\n\n"
+ "TTttTtest\n\n"
+ "TTT ";
final String subst = "\\1\\2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}