using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z])(?=[A-Z][a-z])|([a-z])(?=[A-Z])";
string substitution = @"\1\2 ";
string input = @"SMThingAnotherThingBIGCapitalLetters Test
TTttTtest
TTT ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}