# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src\s*=\s*"[^" ]*\K\h|(?!^)\G[^" ]*\K\h//g;t' <<< "echo \"< i mg a l t=\"\" src=\"http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g \" style=\"height:499px; width:326px\" />\";"