const regex = new RegExp('src\\s*=\\s*"[^" ]*\\K\\h|(?!^)\\G[^" ]*\\K\\h', 'g')
const str = `echo "< i mg a l t="" src="http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g " style="height:499px; width:326px" />";`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);