import re
regex = re.compile(r"src\s*=\s*\"[^\" ]*\K\h|(?!^)\G[^\" ]*\K\h")
test_str = "echo \"< i mg a l t=\"\" src=\"http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g \" style=\"height:499px; width:326px\" />\";"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)