$re = '~src\s*=\s*"[^" ]*\K\h|(?!^)\G[^" ]*\K\h~';
$str = 'echo "< i mg a l t="" src="http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g " style="height:499px; width:326px" />";';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;