use strict;
my $str = 'echo "< i mg a l t="" src="http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g " style="height:499px; width:326px" />";';
my $regex = qr~src\s*=\s*"[^" ]*\K\h|(?!^)\G[^" ]*\K\h~p;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";