import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src\\s*=\\s*\"[^\" ]*\\K\\h|(?!^)\\G[^\" ]*\\K\\h";
final String string = "echo \"< i mg a l t=\"\" src=\"http://d2b38jy50zef8l.cloudfront.net/imagesaug_151537815 9.bookworms - k s p .jp g \" style=\"height:499px; width:326px\" />\";";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}