# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$//;t' <<< "ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%"